aboutsummaryrefslogtreecommitdiffstats
path: root/lib/wx/configure.in
diff options
context:
space:
mode:
authorDan Gudmundsson <[email protected]>2010-11-26 15:10:27 +0100
committerDan Gudmundsson <[email protected]>2010-11-26 15:10:27 +0100
commit8339345b4e7e0b2f6520af9ecf512c7a8e538276 (patch)
tree0f165c27fcd9ce0b3a367c2284ce2a992e6c2d2b /lib/wx/configure.in
parent99a28d961d2d760e98353b55991f1fc51dee06b0 (diff)
parentabc92a6f3b4615e596992eda153da0c09a3c7cbf (diff)
downloadotp-8339345b4e7e0b2f6520af9ecf512c7a8e538276.tar.gz
otp-8339345b4e7e0b2f6520af9ecf512c7a8e538276.tar.bz2
otp-8339345b4e7e0b2f6520af9ecf512c7a8e538276.zip
Merge branch 'dgud/wx/separate-opengl' into dev
* dgud/wx/separate-opengl: Fix non available opengl functions Add lib paths for *bsd variants Initilize opengl after setCurrent Update to OpenGL 4.1 Remove ostype sub dirs below wx/priv Windows and Mac build issues Add dialyser spec Better make dependecies for api generation Split opengl functionality into separate dynamic library
Diffstat (limited to 'lib/wx/configure.in')
-rwxr-xr-xlib/wx/configure.in12
1 files changed, 11 insertions, 1 deletions
diff --git a/lib/wx/configure.in b/lib/wx/configure.in
index 8f8c5ee123..f7128db23a 100755
--- a/lib/wx/configure.in
+++ b/lib/wx/configure.in
@@ -162,16 +162,20 @@ esac
case $host_os in
darwin*)
CFLAGS="-no-cpp-precomp $CFLAGS"
- LDFLAGS="-bundle -flat_namespace -undefined warning -fPIC -framework OpenGL $LDFLAGS"
+ LDFLAGS="-bundle -flat_namespace -undefined warning -fPIC $LDFLAGS"
+ GL_LIBS="-framework OpenGL"
;;
win32)
LDFLAGS="-dll $LDFLAGS"
+ GL_LIBS="-lglu32 -lOpengl32"
;;
mingw32)
LDFLAGS="-shared -fPIC $LDFLAGS"
+ GL_LIBS="-lglu32 -lOpengl32"
;;
*)
LDFLAGS="-shared -fPIC $LDFLAGS"
+ GL_LIBS="-lGL -lGLU"
;;
esac
@@ -217,13 +221,19 @@ if test X"$host_os" != X"win32" ; then
if test X"$ac_cv_header_GL_gl_h" != Xyes ; then
AC_MSG_WARN([No OpenGL headers found, wx will NOT be usable])
CPPFLAGS="$saved_CPPFLAGS"
+ else
+ GL_LIBS="-L/usr/local/lib $GL_LIBS"
fi
+ else
+ GL_LIBS="-L/usr/X11R6/lib $GL_LIBS"
fi
fi
else
AC_CHECK_HEADERS([gl/gl.h],[],[],[#include <windows.h>])
fi
+AC_SUBST(GL_LIBS)
+
CXXFLAGS="$CFLAGS $CPPFLAGS"
CFLAGS="$CFLAGS $CPPFLAGS $C_ONLY_FLAGS"