aboutsummaryrefslogtreecommitdiffstats
path: root/lib/wx/configure.in
diff options
context:
space:
mode:
authorDan Gudmundsson <[email protected]>2012-12-17 16:37:32 +0100
committerDan Gudmundsson <[email protected]>2013-01-09 11:44:29 +0100
commitc722d65fbd9be59bd8698149e3cc1a98096fc345 (patch)
tree65ebc8596668cc226a76918ea0cd0dfaf4c3c055 /lib/wx/configure.in
parent0d6aa3eceb636cf864b50e7d02459e08b3c8b8ef (diff)
downloadotp-c722d65fbd9be59bd8698149e3cc1a98096fc345.tar.gz
otp-c722d65fbd9be59bd8698149e3cc1a98096fc345.tar.bz2
otp-c722d65fbd9be59bd8698149e3cc1a98096fc345.zip
wx: Allow 64 bits compilation on mac, requires wxWidgets-2.9
Testing using wxWidgets-2.9 on mac
Diffstat (limited to 'lib/wx/configure.in')
-rwxr-xr-xlib/wx/configure.in30
1 files changed, 15 insertions, 15 deletions
diff --git a/lib/wx/configure.in b/lib/wx/configure.in
index 4f717de3f7..8a1083e54b 100755
--- a/lib/wx/configure.in
+++ b/lib/wx/configure.in
@@ -80,20 +80,20 @@ fi
## Otherwise skip building wxErlang
AC_CHECK_SIZEOF(void *)
-case $ac_cv_sizeof_void_p-$host_os in
- 8-darwin*)
- if test X"$WX_BUILDING_INSIDE_ERLSRC" != X"true" ; then
- AC_MSG_ERROR([Can not use 64bits wxWidgets on Darwin])
- else
- echo "Can not combine 64bits erlang with wxWidgets on MacOSX, wx will not be useable" > ./CONF_INFO
- WXERL_CAN_BUILD_DRIVER=false
- AC_MSG_WARN([Can not combine 64bits erlang with wxWidgets on MacOSX, wx will not be useable])
- fi
- WXERL_CAN_BUILD_DRIVER=false
- ;;
- *)
- ;;
-esac
+# case $ac_cv_sizeof_void_p-$host_os in
+# 8-darwin*)
+# if test X"$WX_BUILDING_INSIDE_ERLSRC" != X"true" ; then
+# AC_MSG_ERROR([Can not use 64bits wxWidgets on Darwin])
+# else
+# echo "Can not combine 64bits erlang with wxWidgets on MacOSX, wx will not be useable" > ./CONF_INFO
+# WXERL_CAN_BUILD_DRIVER=false
+# AC_MSG_WARN([Can not combine 64bits erlang with wxWidgets on MacOSX, wx will not be useable])
+# fi
+# WXERL_CAN_BUILD_DRIVER=false
+# ;;
+# *)
+# ;;
+# esac
PTHR_CFLAGS="-D_THREAD_SAFE -D_REENTRANT"
@@ -155,7 +155,7 @@ case $host_os in
OBJC_CFLAGS="-ObjC"
fi
fi
- CFLAGS=$saved_CFLAGS
+ CFLAGS="$saved_CFLAGS -Wno-deprecated-declarations"
CPPFLAGS="$CPPFLAGS -D_MACOSX $PTHR_CFLAGS"
;;
mingw32)