aboutsummaryrefslogtreecommitdiffstats
path: root/lib/wx/configure.in
diff options
context:
space:
mode:
authorDan Gudmundsson <[email protected]>2013-10-27 23:23:31 +0100
committerDan Gudmundsson <[email protected]>2013-10-28 12:26:56 +0100
commit1d7472911e14e4885c9111aa21fc201c397be20f (patch)
tree7f7c1f9330cbbf3db4b533e054307a326f78e90d /lib/wx/configure.in
parentb59afc383d66c657671ed8e2acc2f9b6269a496c (diff)
downloadotp-1d7472911e14e4885c9111aa21fc201c397be20f.tar.gz
otp-1d7472911e14e4885c9111aa21fc201c397be20f.tar.bz2
otp-1d7472911e14e4885c9111aa21fc201c397be20f.zip
wx: Enable configure flags --with-wxdir --with-wx-prefix on windows
Diffstat (limited to 'lib/wx/configure.in')
-rwxr-xr-xlib/wx/configure.in20
1 files changed, 18 insertions, 2 deletions
diff --git a/lib/wx/configure.in b/lib/wx/configure.in
index 9c55e544a4..c65e45ca0d 100755
--- a/lib/wx/configure.in
+++ b/lib/wx/configure.in
@@ -413,7 +413,22 @@ define(wx_warn_text,[
fi
else
AC_MSG_CHECKING(for wxWidgets in standard locations)
-
+
+ # Check whether --with-wxdir was given.
+ AC_MSG_NOTICE(OptionCheck: [$with_wxdir $with_wx_prefix])
+
+ if test "${with_wxdir+set}" = set; then :
+ withval=$with_wxdir; CWXWIN0=$withval
+ else
+ # Check whether --with-wx-prefix was given.
+ if test "${with_wx_prefix+set}" = set; then :
+ withval=$with_wx_prefix; CWXWIN0=$withval
+ else
+ echo Setting it empty
+ CWXWIN0=""
+ fi
+ fi
+
if test "x$MIXED_MSYS" = "xyes"; then
CWXWIN_CONFIG=`win2msys_path.sh $wx_config_name 2>/dev/null`
else
@@ -444,9 +459,10 @@ else
;;
esac
- CWXPATH="$CWXWIN1 $CWXWIN2 $CWX_DOCUMENTED $CWXWIN3.* $CWXWIN4.*"
+ CWXPATH="$CWXWIN0 $CWXWIN1 $CWXWIN2 $CWX_DOCUMENTED $CWXWIN3.* $CWXWIN4.*"
for dir in $CWXPATH; do
+ AC_MSG_NOTICE(Checking: [$dir])
if test -f $dir/include/wx/wx.h; then
WXINCLUDE_MSVC=$dir/include/msvc
WXINCLUDE_PLAIN=$dir/include