aboutsummaryrefslogtreecommitdiffstats
path: root/lib/wx/configure.in
diff options
context:
space:
mode:
authorDan Gudmundsson <[email protected]>2012-11-08 08:38:28 +0100
committerDan Gudmundsson <[email protected]>2013-01-09 11:41:41 +0100
commitad6e421879217ee76d3c7267bcd8234ec33153a1 (patch)
tree8a6ab00d5c9be0a8c4cdf497cd83641313a0c7f6 /lib/wx/configure.in
parent05d2434a2ccfe94ea7c7db50189ff440b1517fbe (diff)
downloadotp-ad6e421879217ee76d3c7267bcd8234ec33153a1.tar.gz
otp-ad6e421879217ee76d3c7267bcd8234ec33153a1.tar.bz2
otp-ad6e421879217ee76d3c7267bcd8234ec33153a1.zip
wx: Include correct m4 file in 2.9
The older m4 file will not work with a 2.9 release, so include the correct one in 2.9
Diffstat (limited to 'lib/wx/configure.in')
-rwxr-xr-xlib/wx/configure.in23
1 files changed, 22 insertions, 1 deletions
diff --git a/lib/wx/configure.in b/lib/wx/configure.in
index 7b35fed672..0f84cada51 100755
--- a/lib/wx/configure.in
+++ b/lib/wx/configure.in
@@ -169,6 +169,7 @@ case $host_os in
CPPFLAGS="$CPPFLAGS -D_WIN32_WINNT=0x0500"
;;
*)
+ CFLAGS="$CFLAGS -fpermissive -Wno-deprecated-declarations"
CPPFLAGS="$CPPFLAGS -D_GNU_SOURCE $PTHR_CFLAGS"
;;
esac
@@ -252,6 +253,18 @@ else
AC_CHECK_HEADERS([gl/gl.h],[],[],[#include <windows.h>])
fi
+if test X"$host_os" != X"win32" ; then
+ AC_CHECK_HEADERS([GL/glu.h], [],
+ [AC_CHECK_HEADERS([OpenGL/glu.h])])
+ if test X"$ac_cv_header_GL_glu_h" != Xyes &&
+ test X"$ac_cv_header_OpenGL_glu_h" != Xyes
+ then
+ AC_MSG_WARN([No GLU headers found, wx will NOT be usable])
+ fi
+else
+ AC_CHECK_HEADERS([gl/glu.h],[],[],[#include <windows.h>])
+fi
+
AC_SUBST(GL_LIBS)
CXXFLAGS="$CFLAGS $CPPFLAGS"
@@ -308,7 +321,15 @@ if test "$cross_compiling" = "yes"; then
echo "Cross compilation of the wx driver is not supported yet, wx will NOT be usable" > ./CONF_INFO
WXERL_CAN_BUILD_DRIVER=false
elif test X"$MIXED_CYGWIN_VC" == X"no" -a X"$MIXED_MSYS_VC" == X"no"; then
- m4_include(wxwin.m4)
+ WX_VERSION=`wx-config --version`
+ case $WX_VERSION in
+ 2.8.*)
+ m4_include(wxwin-2.8.m4)
+ ;;
+ *)
+ m4_include(wxwin-2.9.m4)
+ ;;
+ esac
AM_OPTIONS_WXCONFIG
reqwx=2.8.4