aboutsummaryrefslogtreecommitdiffstats
path: root/erts/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'erts/configure.in')
-rw-r--r--erts/configure.in10
1 files changed, 5 insertions, 5 deletions
diff --git a/erts/configure.in b/erts/configure.in
index 5bd8afeea6..4bff2ebf3d 100644
--- a/erts/configure.in
+++ b/erts/configure.in
@@ -2745,22 +2745,22 @@ AC_CHECK_PROG(M4, m4, m4)
if test X${enable_hipe} != Xno; then
- if test X$ac_cv_sizeof_void_p != X4; then
- dnl HiPE cannot run on 64-bit without MAP_FIXED and MAP_NORESERVE
+ if test X$ac_cv_sizeof_void_p != X4 && test X$ARCH = Xamd64; then
+ dnl HiPE cannot run on x86_64 without MAP_FIXED and MAP_NORESERVE
AC_CHECK_DECLS([MAP_FIXED, MAP_NORESERVE], [], [], [#include <sys/mman.h>])
if test X$ac_cv_have_decl_MAP_FIXED != Xyes || test X$ac_cv_have_decl_MAP_NORESERVE != Xyes; then
if test X${enable_hipe} = Xyes; then
- AC_MSG_ERROR([HiPE on 64-bit needs MAP_FIXED and MAP_NORESERVE flags for mmap()])
+ AC_MSG_ERROR([HiPE on x86_64 needs MAP_FIXED and MAP_NORESERVE flags for mmap()])
else
enable_hipe=no
AC_MSG_WARN([Disable HiPE due to lack of MAP_FIXED and MAP_NORESERVE flags for mmap()])
fi
fi
else
- dnl HiPE cannot run on 32-bit without mprotect()
+ dnl HiPE cannot run without mprotect()
if test X$ac_cv_func_mprotect != Xyes; then
if test X${enable_hipe} = Xyes; then
- AC_MSG_ERROR([HiPE on 32-bit needs mprotect()])
+ AC_MSG_ERROR([HiPE needs mprotect() on $ARCH])
else
enable_hipe=no
AC_MSG_WARN([Disable HiPE due to lack of mprotect()])