aboutsummaryrefslogtreecommitdiffstats
path: root/erts/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'erts/configure.in')
-rw-r--r--erts/configure.in16
1 files changed, 14 insertions, 2 deletions
diff --git a/erts/configure.in b/erts/configure.in
index fafa1c7e92..4f0c6efc3e 100644
--- a/erts/configure.in
+++ b/erts/configure.in
@@ -490,7 +490,19 @@ CFLAG_RUNTIME_LIBRARY_PATH="-Wl,-R"
case $host_os in
darwin*)
CFLAG_RUNTIME_LIBRARY_PATH=
- CFLAGS="$CFLAGS -no-cpp-precomp"
+ AC_TRY_COMPILE([],[
+ #if __GNUC__ >= 4
+ ;
+ #else
+ #error old or no gcc
+ #endif
+ ],
+ gcc_need_no_cpp_precomp=no,
+ gcc_need_no_cpp_precomp=yes)
+
+ if test x$gcc_need_no_cpp_precomp = xyes; then
+ CFLAGS="$CFLAGS -no-cpp-precomp"
+ fi
;;
win32)
CFLAG_RUNTIME_LIBRARY_PATH=
@@ -1000,7 +1012,7 @@ case $ERTS_BUILD_SMP_EMU in
],
gcc_smp=okgcc,
gcc_smp=oldornogcc)
- ERTS_BUILD_SMP_EMU=yes
+Ω ERTS_BUILD_SMP_EMU=yes
case "$enable_threads-$gcc_smp-$found_threads-$host_os" in
no-*)