aboutsummaryrefslogtreecommitdiffstats
path: root/erts/configure.in
diff options
context:
space:
mode:
authorMicael Karlberg <[email protected]>2019-05-02 10:16:04 +0200
committerMicael Karlberg <[email protected]>2019-05-02 10:16:04 +0200
commit5c3b8ece50b2dfa66351198375acf4a5f08833ac (patch)
tree2d1d42872f10a68656793638c460c3f76859a8c5 /erts/configure.in
parent202ac7dcd4060b463a08d6bca09529c95d5855f4 (diff)
parentb49f68d5d8a256a7a0847d939b2da8a4be6c728a (diff)
downloadotp-5c3b8ece50b2dfa66351198375acf4a5f08833ac.tar.gz
otp-5c3b8ece50b2dfa66351198375acf4a5f08833ac.tar.bz2
otp-5c3b8ece50b2dfa66351198375acf4a5f08833ac.zip
Merge branch 'bmk/erts/esock/20190430/configure_esock_include/OTP-15658'
Diffstat (limited to 'erts/configure.in')
-rw-r--r--erts/configure.in24
1 files changed, 23 insertions, 1 deletions
diff --git a/erts/configure.in b/erts/configure.in
index 5f969a0a8b..2538505ee7 100644
--- a/erts/configure.in
+++ b/erts/configure.in
@@ -2,7 +2,7 @@ dnl Process this file with autoconf to produce a configure script. -*-m4-*-
dnl %CopyrightBegin%
dnl
-dnl Copyright Ericsson AB 1997-2018. All Rights Reserved.
+dnl Copyright Ericsson AB 1997-2019. All Rights Reserved.
dnl
dnl Licensed under the Apache License, Version 2.0 (the "License");
dnl you may not use this file except in compliance with the License.
@@ -1329,6 +1329,28 @@ LIBS=$zlib_save_LIBS
fi
AC_SUBST(Z_LIB)
+
+dnl -------------
+dnl esock
+dnl -------------
+
+AC_ARG_ENABLE(esock,
+AS_HELP_STRING([--enable-esock], [enable builtin experimental socket (as a nif) support (default)])
+AS_HELP_STRING([--disable-esock], [disable builtin experimental socket (as a nif) support]))
+
+dnl Default value
+USE_ESOCK=yes
+
+if test "x$enable_esock" = "xyes"; then
+ USE_ESOCK=yes
+else
+ if test "x$enable_esock" = "xno"; then
+ USE_ESOCK=no
+ fi
+fi
+AC_SUBST(USE_ESOCK)
+
+
dnl
dnl This test kindly borrowed from Tcl
dnl