aboutsummaryrefslogtreecommitdiffstats
path: root/erts/configure.in
diff options
context:
space:
mode:
authorMicael Karlberg <[email protected]>2019-05-22 14:26:49 +0200
committerMicael Karlberg <[email protected]>2019-05-22 14:26:49 +0200
commit656c2b6e458e34cc0bf82af69b7b98998f02ff0d (patch)
tree361e17c395a939d58ee1650190351f54863c788d /erts/configure.in
parent8551ec93d2864d8122472d8531a5268ee500d38d (diff)
downloadotp-656c2b6e458e34cc0bf82af69b7b98998f02ff0d.tar.gz
otp-656c2b6e458e34cc0bf82af69b7b98998f02ff0d.tar.bz2
otp-656c2b6e458e34cc0bf82af69b7b98998f02ff0d.zip
[esock] Explicitly (configure) check for time functions
Explicitly autoconf check for functions localtime_r and strftime, which are used in prettyfying timestamps. Also make use of the results from these checks (HAVE_...) If not found, timestamps will just be an integer (which is better then nothing). OTP-15566
Diffstat (limited to 'erts/configure.in')
-rw-r--r--erts/configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/erts/configure.in b/erts/configure.in
index 506ce0d0fb..10a006d812 100644
--- a/erts/configure.in
+++ b/erts/configure.in
@@ -1362,6 +1362,13 @@ else
USE_ESOCK=no
fi
fi
+
+if test "x$USE_ESOCK" = "xyes"; then
+ if test "x$USE_ESOCK" = "xyes"; then
+ AC_CHECK_FUNCS([localtime_r strftime])
+ fi
+fi
+
AC_SUBST(USE_ESOCK)