aboutsummaryrefslogtreecommitdiffstats
path: root/erts/configure.in
diff options
context:
space:
mode:
authorBjörn Gustavsson <[email protected]>2016-03-16 12:00:54 +0100
committerBjörn Gustavsson <[email protected]>2016-03-16 12:00:54 +0100
commitae61174845dde2ddda537d57ace5b1124b7f4191 (patch)
tree6464a94a1c323e397cd6dd5cbb9fd8469587f31d /erts/configure.in
parentcee5b753e8dbd294b2677f684c404d16dcfcd643 (diff)
parent395fbd8d02cb314b8ae57b9c02b4293037ca6890 (diff)
downloadotp-ae61174845dde2ddda537d57ace5b1124b7f4191.tar.gz
otp-ae61174845dde2ddda537d57ace5b1124b7f4191.tar.bz2
otp-ae61174845dde2ddda537d57ace5b1124b7f4191.zip
Merge branch 'bjorn/fix-broken-osx-build'
* bjorn/fix-broken-osx-build: Take out (parts of) broken fp exception support for MacOS X configure.in: Fix compilation error in ethread.c run_erl: Don't define _XOPEN_SOURCE on OS X
Diffstat (limited to 'erts/configure.in')
-rw-r--r--erts/configure.in41
1 files changed, 0 insertions, 41 deletions
diff --git a/erts/configure.in b/erts/configure.in
index 021780ecc2..cae3843465 100644
--- a/erts/configure.in
+++ b/erts/configure.in
@@ -476,9 +476,6 @@ case $host_os in
# -D_WIN32_WINNT=* from CPPFLAGS is saved in ETHR_DEFS.
CPPFLAGS="$CPPFLAGS -D_WIN32_WINNT=0x0600 -DWINVER=0x0600"
;;
- darwin*)
- CPPFLAGS="$CPPFLAGS -D_XOPEN_SOURCE"
- ;;
*)
;;
esac
@@ -2810,44 +2807,6 @@ if test "$cross_compiling" != "yes" && test X${enable_hipe} != Xno; then
fi
fi
-case $ARCH-$OPSYS in
- amd64-darwin*|x86-darwin*)
- AC_MSG_CHECKING([For modern (leopard) style mcontext_t])
- AC_TRY_COMPILE([
- #include <stdlib.h>
- #include <sys/types.h>
- #include <unistd.h>
- #include <mach/mach.h>
- #include <pthread.h>
- #include <machine/signal.h>
- #include <ucontext.h>
- ],[
- #if defined(__APPLE__) && defined(__MACH__) && !defined(__DARWIN__)
- #define __DARWIN__ 1
- #endif
-
- #ifndef __DARWIN__
- #error inpossible
- #else
-
- mcontext_t mc = NULL;
- int x = mc->__fs.__fpu_mxcsr;
-
- #endif
- ],darwin_mcontext_leopard=yes,
- darwin_mcontext_leopard=no)
- if test X"$darwin_mcontext_leopard" = X"yes"; then
- AC_DEFINE(DARWIN_MODERN_MCONTEXT,[],[Modern style mcontext_t in MacOSX])
- AC_MSG_RESULT(yes)
- else
- AC_MSG_RESULT(no)
- fi
- ;;
- *)
- darwin_mcontext_leopard=no
- ;;
-esac
-
if test X${enable_fp_exceptions} = Xauto ; then
case $host_os in
*linux*)