aboutsummaryrefslogtreecommitdiffstats
path: root/lib/common_test/test/common_test.spec
diff options
context:
space:
mode:
authorSiri Hansen <[email protected]>2012-05-07 12:21:02 +0200
committerSiri Hansen <[email protected]>2012-08-17 11:14:37 +0200
commitcfff69a3a181f2092bc4a085ca677b1b5735bda7 (patch)
tree23170e8a476cd285f9adaa7a646bba87bd6efa97 /lib/common_test/test/common_test.spec
parent68e0078eb58803dc4a7e0bfd801f32c2c92b7f26 (diff)
downloadotp-cfff69a3a181f2092bc4a085ca677b1b5735bda7.tar.gz
otp-cfff69a3a181f2092bc4a085ca677b1b5735bda7.tar.bz2
otp-cfff69a3a181f2092bc4a085ca677b1b5735bda7.zip
[common_test] Add netconf client, ct_netconfc
The netconf client supports basic netconf functionality over SSH. In order to allow testing of both success and failure cases, it is intentionally written to allow non-standard behavior. In order for the netconf client to use the generic connection mechanism in common_test, ct_gen_conn has been updated to be more flexible: Added options: {reconnect,bool()} {forward_messages,bool()} {use_existing_connection,bool()} Allow handle_msg to return {reply,Reply,State} | {noreply,State} | {stop,Reply,State} If forward_messages==true, the ct_gen_conn callback must also implement: handle_msgs(Msg,State) -> {noreply,State} | {stop,State}
Diffstat (limited to 'lib/common_test/test/common_test.spec')
-rw-r--r--lib/common_test/test/common_test.spec3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/common_test/test/common_test.spec b/lib/common_test/test/common_test.spec
index 8755b08117..04f3c64442 100644
--- a/lib/common_test/test/common_test.spec
+++ b/lib/common_test/test/common_test.spec
@@ -1 +1,2 @@
-{suites,"../common_test_test",all}. \ No newline at end of file
+{suites,"../common_test_test",all}.
+{config,"../common_test_test/ct_netconfc.cfg"}. \ No newline at end of file