aboutsummaryrefslogtreecommitdiffstats
path: root/lib/wx/configure.in
diff options
context:
space:
mode:
authorDan Gudmundsson <[email protected]>2010-10-11 11:00:38 +0200
committerDan Gudmundsson <[email protected]>2010-11-15 10:13:07 +0100
commit8577598667bff43f503f3cae87934c3e9918d135 (patch)
tree7769951ae687f9c266ee938f0df221e291699529 /lib/wx/configure.in
parentac433c8318566261a74ffe7fd0824fb99610bed3 (diff)
downloadotp-8577598667bff43f503f3cae87934c3e9918d135.tar.gz
otp-8577598667bff43f503f3cae87934c3e9918d135.tar.bz2
otp-8577598667bff43f503f3cae87934c3e9918d135.zip
Windows and Mac build issues
Diffstat (limited to 'lib/wx/configure.in')
-rwxr-xr-xlib/wx/configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/lib/wx/configure.in b/lib/wx/configure.in
index 8f8c5ee123..a2e5ff0bf7 100755
--- a/lib/wx/configure.in
+++ b/lib/wx/configure.in
@@ -162,19 +162,25 @@ esac
case $host_os in
darwin*)
CFLAGS="-no-cpp-precomp $CFLAGS"
- LDFLAGS="-bundle -flat_namespace -undefined warning -fPIC -framework OpenGL $LDFLAGS"
+ LDFLAGS="-bundle -flat_namespace -undefined warning -fPIC $LDFLAGS"
+ GL_LIBS="-framework OpenGL"
;;
win32)
LDFLAGS="-dll $LDFLAGS"
+ GL_LIBS="-lglu32 -lOpengl32"
;;
mingw32)
LDFLAGS="-shared -fPIC $LDFLAGS"
+ GL_LIBS="-lglu32 -lOpengl32"
;;
*)
LDFLAGS="-shared -fPIC $LDFLAGS"
+ GL_LIBS="-lGL -lGLU"
;;
esac
+AC_SUBST(GL_LIBS)
+
dnl ----------------------------------------------------------------------
dnl Include CPPFLAGS in CFLAGS
dnl ----------------------------------------------------------------------