aboutsummaryrefslogtreecommitdiffstats
path: root/make/configure.in
diff options
context:
space:
mode:
authorRickard Green <[email protected]>2018-07-18 15:14:29 +0200
committerRickard Green <[email protected]>2018-08-21 17:40:59 +0200
commitb3f4e9ee21b1f400b3c26c18c56ebc1ec13b5b4e (patch)
tree8416d3b946a107acfaa92eeaaf5b0e5fd4949247 /make/configure.in
parentd4b456742b8bdab6222008ffd20e3d086b646e3f (diff)
downloadotp-b3f4e9ee21b1f400b3c26c18c56ebc1ec13b5b4e.tar.gz
otp-b3f4e9ee21b1f400b3c26c18c56ebc1ec13b5b4e.tar.bz2
otp-b3f4e9ee21b1f400b3c26c18c56ebc1ec13b5b4e.zip
Move configuration of crypto to crypto application from erts
In order to be able to handle runtime library path in crypto also DED parts was broken out into a macro.
Diffstat (limited to 'make/configure.in')
-rw-r--r--make/configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/make/configure.in b/make/configure.in
index c390e1ca31..987e02ddc1 100644
--- a/make/configure.in
+++ b/make/configure.in
@@ -93,6 +93,8 @@ dnl
if test "X$host" != "Xfree_source" -a "X$host" != "Xwin32"; then
AC_CANONICAL_HOST
+else
+ host_os=$host
fi
TARGET=$host
@@ -128,6 +130,8 @@ AC_PROG_CC
AC_PROG_CXX
AC_CHECK_TOOL(LD, [ld])
+LM_WINDOWS_ENVIRONMENT
+
_search_path=/bin:/usr/bin:/usr/local/bin:$PATH
AC_PATH_PROG(ENV, [env], false, $_search_path)
@@ -415,7 +419,9 @@ if test $CROSS_COMPILING = no; then
esac
fi
-AC_CONFIG_FILES([../Makefile output.mk])
+ERL_DED
+
+AC_CONFIG_FILES([../Makefile output.mk ../make/$host/otp_ded.mk:../make/otp_ded.mk.in])
AC_CONFIG_FILES([emd2exml], [chmod +x emd2exml])
AC_OUTPUT